Перейти к содержимому
Форум журнала практической электроники «Датагор»

Оригинал микро-ПК Raspberry Pi 3 Model B+ (Broadcom 1.4GHz quad-core 64 bit processor, Wifi, Bluetooth, USB)

Офигенная миниатюрная рация на литии BaoFeng UV-5R, 5W, 5-15 км! Охота, поход, торговый центр и т.п.

TrueRMS мультиметр UNI-T UT139A с автодиапазонами

Паяльнник 80W с терморегулятором и LCD-дисплеем, популярные жала серии 900M
Гость K.A.

Стабилизированный лабораторный блок питания 0-30В 0,002-3А

Рекомендованные сообщения

Посты для "солидности" набираете ...? :)

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах
Гость alx25v

ща насяльника позову

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Уважаемый, Lexter

 

Я прочитал всю тему про этот БП и решил что скорее всего именно Вы сможете вникнуть в мой вопрос, хотя обращаюсь конечно же ко ВСЕМ форумчанам.

 

Итак.....

Я собрал эту схему по набору, правда набор заказал не из Китая, а в Украине - они там клоны этих наборов делают, ну и описание краткое работы схемы на русском прикладывают.

Схема у меня заработала сразу. Я подключил осциллограф и сделал измерения. На выходе все красиво и ровно. Пульсации 100 Гц появляются только когда напряжение выхода близко к напряжению питания, но это так и должно быть потому что ОУ2 (ТЛ081) на выходе близко к напряжению питания естественно начинает выдавать пульсации. Под нагрузкой на осциллографе тоже все красиво и ровно, ну по крайней мере на 100Гц ничего не видно на экране при делении 10 м/сек. Нагрузку давал до 2 А.

Далее начал смотреть как работает ограничение по току, то есть при регулировке потенциометра Р2 компаратор ОУ3 выключает на выходе напряжение питания (чуть меньше естественно), затем открывается диод Д9 и соответственно снижается напряжение на +входе ОУ2...ну и далее на выходе БП, при всем этом загорается светодиод.

Так вот все именно так у меня и работает, НО сразу после включения в работу ОУ3 на выходе БП на экране осциллографа появляются пульсации 100Гц.

Я прошелся щупом осциллографа по точкам и убедился что пульсации лезут именно с выхода ОУ3 и далее через ОУ2 вылазят на выходе БП. То есть пока диод Д9 закрыт, то пульсации на выходе ОУ3 не мешают, но при открытом Д9 и снижении напряжения на выходе ОУ3, а вернее появления там напряжения от + входа ОУ2 через диод Д9, выход ОУ3 все равно пульсирует.

Возможно я путанно все обрисовал, но надеюсь Вы поймете меня. В конечном итоге простыми словами так:

Пока кручу потенциометр Р1 от 0 почти до максимума - пульсаций 100Гц на осциллографе нет. А как только начинаю потенциометром Р2 зажимать напряжение для ограничения тока, так сразу вылазят пульсации.

 

Как решить эту проблему??

 

Возможно это происходит из за того что ОУ3 включен как компаратор и на его выходе или плюс питания или минус питания и в этих режимах ТЛ081 всегда будет выдавать пульсации....но я в этой версии не очень уверен.

Может попробовать включить ОУ3 по другому, ну в смысле не как компаратор, а как например линейный инвертирующий усилитель, который будет как бы не убирать полностью плюс питания на своем выходе. а будет плавно снижать его?? Попробовать прилепить к ОУ3 ООС?

Моих познаний на такое изменение схемы не хватает, может подскажете как заставить работать ОУ3 без пульсаций на его выходе??

 

И еще, сразу добавлю, что ОУшка у меня нормальная, я переставлял в панельке несколько штук и всегда работает одинаково.

 

Спасибо.

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах
... Для последовательной нет элементов с нужной ВАХ. ...

Николай, если приладить к параллельному параметрическому стабилизатору на стабилитроне эмиттерный повторитель, включенный последовательно с нагрузкой, получится последовательный параметрический стабилизатор...

Изменено пользователем drummer

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах
... собрал эту схему ...

Дмитрий, схему покажите...

... Как решить эту проблему?? ...

Проблема то в чём ??? :smug:

Режим ограничения тока в лабораторных БП - режим аварийный, для предотвращения серьёзных повреждений питаемого изделия, в случае, если, что то "пошло не так"...

При "отсечке" тока , если нет блокирующего триггера, возможно не только увеличение пульсаций, но и самовозбуждение системы "БП + нагрузка".

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах
... получится последовательный параметрический стабилизатор...
Да.

 

... как заставить работать ОУ3 без пульсаций на его выходе? ...
Возможно поможет, если "-" питания U1 перекинуть на "-5", как у остальных ОУ. И не забудьте поставить ёмкости по питанию ОУ непосредственно около их выводов (с вывода 7 на вывод 4).

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Да.

 

Возможно поможет, если "-" питания U1 перекинуть на "-5", как у остальных ОУ. И не забудьте поставить ёмкости по питанию ОУ непосредственно около их выводов (с вывода 7 на вывод 4).

Ок, спасибо...сейчас попробую перекинуть питание ОУ1 на отрицательное плечо и отпишусь...

А емкости подскажите номинал плз...а то на схеме их вообще нет

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах
... емкости подскажите номинал ...
Как минимум, должны стоять 0,1 мкФ между выводами питания каждого ОУ. Это минимальное требование для обеспечения устойчивости ОУ. Без них ОУ имеет право возбуждаться.

Рабочее напряжение этих ёмкостей не менее (1,4 * напряжение питания).

Изменено пользователем Lexter

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

 

Возможно поможет, если "-" питания U1 перекинуть на "-5", как у остальных ОУ. И не забудьте поставить ёмкости по питанию ОУ непосредственно около их выводов (с вывода 7 на вывод 4).

Нет, так ничего не получится. При таком питании ОУ1 стаб Д8 не открывается и на выходе ОУ1 примерно минус 0,5 вольта....то есть ОУ1 никому ничего не раздает и схема молчит.

Можно попробовать минус питания ОУ1 перекинуть на "полный ноль", т.е. после шунта R7 а не до него как сейчас по схеме....может это на что нибудь повлияет??

Хотя, я не понимаю причем тут ОУ1 ?? Ведь проблема не с ОУ1 а с ОУ3, которая ток ограничивает. Если бы проблема была в ОУ1, которая стабилизированное опорное раздает, то тогда пульсации на выходе ОУ2 тоже были бы всегда, а так пульсации есть только на выходе ОУ3.

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Тут вот еще что увидел пока по точкам схемы замеры делал...

На стабе Д7, который создает минус 5,6 вольта для отрицательного питания ОУ3 и ОУ2 напряжение не постоянно -5,6 В.

На холостом ходу без нагрузки при регулировки напряжения на выходе, напряжение на стабе Д7 постоянно -5,6 В. А вот при увеличении напряжения с нагрузкой по мере того как проседает напряжение на + входного конденсатора С1 при росте тока от 0 до 3 А, напряжение на этом стабе Д7 увеличивается (в смысле УЕНЬШАЕТСЯ) с -5,6 аж до -7,2 вольта. Это нормально или так не должно быть??

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах
... при росте тока от 0 до 3 А, напряжение на этом стабе Д7 увеличивается (в смысле УЕНЬШАЕТСЯ) с -5,6 аж до -7,2 вольта. ...
Да, так происходит из-за увеличения падения напряжения на резисторе R7 по мере увеличения тока нагрузки. Ровно на величину этого падения напряжения.

 

... При таком питании ОУ1 стаб Д8 не открывается и на выходе ОУ1 примерно минус 0,5 вольта ...
Да, не подумал. Эта схема источника опорного напряжения не запустится при двуполярном питании. Верните, как было.

Насчёт "ОУ3 включен как компаратор". Вообще-то, это интегратор, и стабилизация тока происходит в линейном режиме. Когда напряжение на выводе 3 превысит напряжение на выводе 2, напряжение на выходе начинает плавно возрастать, а потом стабилизируется на каком-то значении, соответствующем установленному току. Может, в вашей схеме что-то не то с номиналами элементов C8 и R21?

(Нумерация элементов по схеме из статьи Стабилизированный лабораторный блок питания 0-30В 0,002-3А)

Изменено пользователем Lexter

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Да, так происходит из-за увеличения падения напряжения на резисторе R7 по мере увеличения тока нагрузки. Ровно на величину этого падения напряжения.

 

Да, не подумал. Эта схема источника опорного напряжения не запустится при двуполярном питании. Верните, как было.

Насчёт "ОУ3 включен как компаратор". Вообще-то, это интегратор, и стабилизация тока происходит в линейном режиме. Когда напряжение на выводе 3 превысит напряжение на выводе 2, напряжение на выходе начинает плавно возрастать, а потом стабилизируется на каком-то значении, соответствующем установленному току. Может, в вашей схеме что-то не то с номиналами элементов C8 и R21?

(Нумерация элементов по схеме из статьи Стабилизированный лабораторный блок питания 0-30В 0,002-3А)

Про R7 я понял и изначально не совсем правильно описал ситуацию. На этом стабе в любом состоянии падает 5,6 вольта, просто с ростом тока на шунте увеличивается падение напряжения и ровно на это значение уменьшается на общей земле, ну или на минусе входного С1. То есть если на стабе Д7 стало -7,2, то на минусе С1 стало -1,6 В. Как то так, и на мультиметре так все и есть....

 

Николай, спасибо что не бросаете..... :wink:

Номиналы я проверил, да я всегда перед установкой деталей на плату проверяю ВСЕ без исключения и пассивные и активные разными тестерами. Номиналы в пределах нормы. Ну вот С8 у меня 350 пф, а по схеме 330 пф.....но это ведь не криминал??

Есть у меня изначальное отличие только в двух конденсаторах формирующих отрицательное плечо С2 и С3. По схеме они 47 μF, а у меня стоят по 200 μF. Но это ведь тоже не может влиять на пульсации ОУ3??

В остальном все компоненты такие же как в статье по китайской схеме.

 

Я немного запутался с режимами работы этого ОУ3. Получается что пока на его входе +(3) напряжение выше чем на входе -(2), то он включен как бы компаратором, ну и соответственно на его выходе (6) напряжение +питания (я проверял -там чуть меньше как и должно быть) и при этом естественно диод Д9 закрыт и мы регулируем напряжение потенциометром Р1 как хотим. Но как только мы потенциометром Р2 снижаем опорное напряжение на +(3) входе ОУ3 ниже чем оно в данный момент на -(2) входе, то в этот момент на выходе компаратора ОУ3 исчезает напряжение + питания (чуть меньше) и как бы должно появиться -питания и появляется -4,1 В (я проверял отключив Д9). НО поскольку есть в схеме Д9, то в момент его неизбежного открытия в такой ситуации ОУ3 перестает быть компаратором, поскольку получает через Д9 обратную связь через весь контур схемы включая ОУ2, нагрузку и шунт и становится линейным инвертирующим усилителем и начинает формировать на своем выходе такое напряжение, которое должен для создания равенства напряжений на своих входах.....так что ли??? Причем просчитать эту ООС я не представляю как?? Просто весь контур стабилизируется на заданном нами уровне тока.....

Ну если я все правильно представляю, то откуда на выходе ОУ3 100Гц берутся??

Может попробовать ТЛ071 вместо ТЛ081 на его место воткнуть в панельку?? У меня есть ТЛ071....

Изменено пользователем dima1967

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Пожалуйста, войдите для комментирования

Вы сможете оставить комментарий после входа



Войти сейчас

  • Сейчас на странице   0 пользователей

    Нет пользователей, просматривающих эту страницу

  • Сообщения

    • Здравствуйте. Много лет назад приобрел по случаю такие же колонки, как у автора темы, 4а32 -2шт + 3гд38 - 4шт. Все это время они стояли без дела, и вот появилась потребность в источнике, способном озвучить относительно большое помещение, более 50 квадратов с потолком 3 метра. "Бытовые" колонки с такой задачей справляются частично. Венец, в общем-то, осиливает, но качество звука... Низ слабоват, верха нет. С какой целью туда напихали 3гд38 - я не в состоянии понять. После 12-13 килогерц вся система выдает тишину, уверенное затухание ВЧ начинается уже с 10. Что за корпус - тоже неясно. Кто это все считал (если вообще считал), где там резонансы, что это за щель, фазоинвертор или как - мне это неведомо, но глядя на 4 штуки 3гд38, я сомневаюсь, что инженерный мозг участвовал в создании этого устройства. В общем, прошу помощи у сообщества в принятии решения, что делать с этой системой - пристрелить  продать сразу и на вырученные средства делать вклад во что-то более приличное (а во что и сколько оно будет стоить?) или все же заниматься ее улучшением? Вкидывать значительные суммы в апгрейд системы мне нежелательно. Можно ли обойтись сравнительно небольшими затратами при улучшении АЧХ системы? Чем ее улучшать? Автор проделал работу по замене 3гд38, но в первой модернизации использовал недешевый Fountek, а во второй - 25ГДВ-23Д, который я не знаю, где взять без поисков и/или переплат. 
    • Здравствуйте.Да случилась и у меня такая беда.Раз поменял термисторы,два,три.А в итоге IVAN_BY оказался абсолютно прав.Всё дело в релюшке,которая на его схеме находится под термистором.Поменял реле и забыл проблему
    • Здравствуйте, давно не заходил сюда, за это время мои колонки пережили глубокую модернизацию, это уже совсем другая технология, установлены другие динамики, на вч wavecor tw022-wa05-01, на сч beyma 3fr30, нч оставил те же 25гдн3-4, переделаны разделительные фильтры, оставил пассивными только сч/вч, нч/сч теперь на активных кроссоверах, это потребовало увеличить количество усилителей, поэтому был куплен второй такой же ресак, итого теперь на всю систему работают 13 усилителей)) не считая сабвуфера. Частоты раздела выбрал 600 и 5000гц, корректнее сказать что в работу включаются писчалки от 5кгц, beyma тянет вч вполне нормально, только выброс ачх на 15кгц придавил режекторным фильтром. Корпуса фронтальных колонок заменил новыми, поцивильнее.
    • Да не, дело точно не в кварце или кнопках. Все остальные режимы начинают нормально работать сразу после включения. Не включается только режим постоянного тока/напряжения. Всё же подозреваю конденсатор. Вопрос какой? Очень не хочется все перепаивать.  
    • Диоду конец. замкнут в обе стороны из-за чего не понял
    • Ну тут вообще две детали. Элементарно же проверяется, куда делось.
    • Хорошо, хорошо. Восемь. Предположим, что из-за ёмкости. Неправильное переключение режимов - это контроллер. Из-за ёмкостей по питанию он вряд ли будет сбоить. Разве что какая-то из ёмкостей в цепи сигнала с огромной утечкой, которая уменьшается после минуты "прогрева"... Сначала долго как-то что-то коротит, и контроллер думает, что подано напряжение, поэтому и не уходит из этого режима...   А из-за кварца - может легко. Тем более, судя по схеме из инета, он на 4 МГц, но в "часовом" корпусе, и шунтирующих ёмкостей по схеме нет... Я бы туда ткнулся, посмотрел. Ну, если ещё поднапрячься что-нибудь придумать, - ну из-за кнопки какой залипшей что-то теоретически может быть, но скорее в данном случае эта гипотеза из области фантастики. Ну вот что может происходить с кнопкой за минуту после включения...   Может плату спиртиком промыть?
    • помыл водой с содой, потом чистой теплой водой, затем спиртом. ничего не поменялось. пока думал, пропал -5.6в на D7 мыл без ОУ. -5.6в после мойки был. решил отогнуть 6 ножку и проверить выход с исключением испорченного текстолита. 0 вольт. вот после этого пропал -5.6
    • спасибо большое за советы. времени пока нет. но сегодня как нибудь займусь мойкой. если не получится, сделаю новую плату
    • Опааа! Вылезло чего не ждали... Уважаемый, это флюс для пайки АЛЮМИНИЯ. Флюс с кислотой. Думал у вас на фото цвет пайки такой тёмно-серый из-за хренового припоя и перегрева, а оно вон что... Нельзя паять платы с кислотой! Хрен её потом отмоешь, а она проводящая. Что у вас сейчас творится на плате, даже гадать бесполезно. Кислота впитывается в текстолит и между произвольными точками схемы получаются непредсказуемые соединения, а места пайки выводов могут между припоем и медью окислиться, сопротивление контакта может увеличиться вплоть до полной потери электрического соединения.  На такой плате любые чудеса наблюдать можно. Если нет новой платы, можно попробовать долго-долго промыть плату (и всё остальное, что вы им паяли) в тазике в проточной горячей воде, высушить хорошенько феном при 70 - 80 градусах, а потом промыть ещё и спиртом (в воде есть соли). Да и то нет гарантии, что кислота не впиталась в текстолит так, что не промоешь. Засуньте этот флюс в самый дальний угол, пока вам алюминий паять не понадобится. Флюс для пайки плат должен быть нейтральный. Идеально в радиолюбительской практике - раствор канифоли в спирте. Покупать флюс надо вдумчиво, только предназначенный для пайки плат. Даже с флюсом ЛТИ можно нарваться на хреновый состав. Если купите готовый, сначала его проверьте. Нанесите пятно размером с гривенник толстым слоем на чистый стеклотекстолит, чуть подсушите и ещё густой проверьте тестером. При расстоянии между ткнутыми в него щупами 2 - 5 мм, сопротивление должно быть по крайней мере более нескольких мегаом.   Продолжать проверять эту плату пока бессмысленно.
    • что-то другие изображения не могу прислать
    • отмываю чистым спиртом, зубной щеткой и протираю сухими салфетками  
    • Лучше научиться проверять схемы. А купить проще вообще готовый - собранный настроенный в корпусе.   TL081 сжечь трудно. Покажите фото с двух сторон, что у вас сейчас собрано. Только чтобы было видно и куда уходят провода с платы. Чем паяете, какой флюс применяете, чем его отмываете?
    • нет. всё нормально. не может быть что все три ОУ сгорели. хотя... по моему лучше купить новый
    • И это?   Сейчас у вас все признаки, что вы сожгли ОУ. Если на инвертирующем входе (вывод 2) напряжение около нуля, а на неинвертирующем (вывод 3) - несколько вольт, то выход ОУ должен "залипнуть" в максимальном положительном напряжении. И не важно, подключен транзистор, соединено R15 с R12 накоротко, или вообще выход ОУ оборван. Если на выходе ОУ практически ноль вольт, то либо выход с чем-то замкнут, что не даёт подняться напряжению, либо на ОУ нет положительного питания, либо ОУ сгорел. Выходные клеммы блока не замкнуты, случайно?   Провод к тестеру от выхода ОУ отпаяйте. Лучше так не делать, потому что длинный "болтающийся" провод может быть причиной самовозбуждения. Кстати, другой конец этого провода ни на что случайно не замыкает?
    • Всё проверил. Всё сделал как написали. без изменений. сейчас на замыкание проверю
    • на тестер, чтобы щупом не коротнул с соседним выводом 27в Как на выходе моста
    • Чтобы в тестере что-то прогревалось... Фантастика какая-то. Ёмкости? Так там их практически и нет... пара электролитов фактически параллельно батарейкам. Это ж не импульсный БП, чтоб параметры ёмкости сильно на работу влияли... Единственное, что могу предположить - что-то с кварцевым резонатором, не сразу нормально запускается.    
    • Может "+" питания на ОУ отвалился? Проверьте напряжение на выводе 7 ОУ. А что за провод у вас припаян непосредственно к выводу 6 этого ОУ (на фото монтажа - толстый грязно-серо-зелёный, уходит вправо)?
    • Странно, что перед этим у вас напряжение на выходе ОУ менялось, значит был исправен. Сейчас, как вы описываете, - ОУ мёртвый. Что-то не так вы собрали. Проверьте монтаж на соответствие схеме. Желательно "прозвонкой" тестера проверить соединения. Посмотрите, нет ли замыканий на что-нибудь в районе выходных клемм. Проверьте, не перепутали ли выводы транзистора.   Для проверки, "жив" ли ещё ОУ, можете попробовать опять отсоединить верхний вывод R15 от базы Q4 и замкнуть его на правый вывод R12. Можно его пока вообще снять.
    • Не похоже, все остальные режимы работают нормально, да и индикатор бы показывал, что батарейки сели. Через несколько минут после включения все режимы работают нормально.
    • так и есть 0.15-0.19в 0.17в   вроде нормально. серой полоской верх
︽ Наверх страницы ︽
×
×
  • Создать...