Перейти к содержимому
Форум журнала практической электроники «Датагор»

Оригинал микро-ПК Raspberry Pi 3 Model B+ (Broadcom 1.4GHz quad-core 64 bit processor, Wifi, Bluetooth, USB)

Офигенная миниатюрная рация на литии BaoFeng UV-5R, 5W, 5-15 км! Охота, поход, торговый центр и т.п.

TrueRMS мультиметр UNI-T UT139A с автодиапазонами

Паяльнник 80W с терморегулятором и LCD-дисплеем, популярные жала серии 900M
Гость jozik

Программатор Avr 910

Рекомендованные сообщения

Гость jozik

Статья на нашем портале - Программатор AVR 910

 

Собрал я...включаю, загорается диод питания, меряю напругу, все ок как и должно быть..3.6-3.7 к ножке мк...

комп определил уст-во, ставлю дрова...все вродь норм...

НО когда пытаюсь что-либо сделать (рид или програм) то загорается на секунду диод второй и сразу тухнет, а на экране вылазит типа "avrprog error entering programming mode" и так всегда, при любом "обращении" к нему.. :smile:

 

что посоветуете? оО

Спасип

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах
Гость guntisk
Гунтис, выручай!!!

 

Иду на помощь!

У данного программатора одна особенность- он отказывается читать и програмить МК если к выводу МК XTAL1 неподключен сигнал LED. LED это как бы тактовый сигнал. Сначало я и сам непонял в чем дело- подумал что неправильно собрал схему. Но оказалось что надо всего то подсоединить один провод...

Вот такие вот дела. :smile:

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах
Гость alx32

В дополнении к сказанному, добавлю, что этот сигнал используется только если у МК не включен встроенный RC-генератор, а внешний кварц не подключен (или не предусмотрен), или же были испорчены "фьюзы" (например включено внешнее тактирование, или выбран не тот тип резонатора). К стати, внутренний RC-генератор есть во всех контроллерах семейства "mega" и включен по умолчанию, а частота установлена в 1 МГц.

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

jozik, как дела, отпишись!

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах
Гость jozik
jozik, как дела, отпишись!

Отписываюсь, луча позно чем никогда, в лс решили с Гунтисом, раньше чем тут просто, все окей, проблема была со шлейфиком...

А вообще такое случается когда не только ЛЕД не подсоединен, а когда вообще мк не присоединен правильно, если хоть одна ножка мисо, моси и тыпы, не соеденены, как надо, то будет такая шняга... (;

 

Пасип Гунтису еще рас (((;

п.с.2Гунтис: Робота пока еще не домучал...времени не было );

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах
Гость format

У меня тоже такая проблема была, там немного не правильная схемка ее нужно переделать. пустить на прямую +5 вольт без диодов.

и поставить 2 стабилитрона на 3.6 вольта одной ножкой к данным другой на корпус.

 

После этого у меня заработало мгновенно! Удачи!

Если что пишите.

post-466-1231779243.jpg

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах
Гость amidima

Всем Привет . И я решил встрять в тему .Собирал как у Протоса ,собрал прошил И контролер не ответил .Оказывается с прошитыми (установлены в "0") биты SPIEN, CKOPT, SUT0 и BODEN он и неопределится (яшил в Uniprof и прогер от Hиколаева COM.

 

Ладно подумал почитал разобрался, включил CodeVisionAVR определил а контролер не читает соответственно не пишет.

Фигня, MOSI и MISO местами перепутал,

а дальше ШОКОЛАД!

post-498-1232050916_thumb.jpg

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах
Гость guntisk
У меня тоже такая проблема была, там немного не правильная схемка ее нужно переделать. пустить на прямую +5 вольт без диодов.

и поставить 2 стабилитрона на 3.6 вольта одной ножкой к данным другой на корпус.

Там всё правильно- и с диодами пашет как надо. :smile: По краине мере у меня уже три программатора собрано. Но должен согласится-со стабилитронами лучще будет. :smile:

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах
Гость saschai
Там всё правильно- и с диодами пашет как надо. :smile: По краине мере у меня уже три программатора собрано. Но должен согласится-со стабилитронами лучще будет. :smile:

Собрал уже штук восемь (для себя любимого в разном исполнении, для знакомых, ну и...), если повторять один в один (с диодами) наиболее стабильный результат, со стабилитронами, как не парадоксально запускаются, не на каждом компе, а вообще как показывает статистика, многое зависит от самого компа, иногда проверенный и полностью рабочий, на отрез отказывается работать и помогает только, как правило, подключение через усб концентратор :smile:

Кстати побывал вместо диодов ставить стабилизатор LM1117на 3,3в, но тут надо еще по шаманить...все таки наиболее стабильно работает при напряжении 3.5-3.7v

PS основная засада при запуске, кварцевый генератор, частенько, достаточно пальцем тыркнуть вывод XTAL1, и о чудо...все пошло, до следующего запуска, помогает замена кварца, хотя он работоспособен на 100%, подбор пары конденсаторов(18-33 пф). Не знаю с чем связано, но иногда спасает замена СМД конденсаторов, в генераторе, на обычные? честно говоря с СМД у меня ни один так стабильно и не заработал

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах
Гость guntisk

Я во всех схемах с МК использую простую керамику (конденсаторы). А с СМДшными да-бывает такая бяка что отказывает работать...

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах
Гость einshteynn

Товарищи,а куда его подключать, кто какой адаптер использует?

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах
Гость
Эта тема закрыта для публикации сообщений.

  • Сейчас на странице   0 пользователей

    Нет пользователей, просматривающих эту страницу

︽ Наверх страницы ︽
×
×
  • Создать...