Перейти к содержимому
Форум журнала практической электроники «Датагор»
Гость химик

Неполадки с выходом звуковухи ноутбука HP Pavilion G6

Рекомендованные сообщения

Гость химик

Здравствуйте. Проблема вот в чем. Левый канал стал работать очень тихо после того, как я попытался воткнуть корявый штекер наушников в гнездо. На наушниках переломился провод около штекера, я купил в магазине разборной металлический штекер. Но после замены, забыл обработать его напильником. Оказалось что ∅ изоляторов между контактами немного шире чем ∅ штекера. Он не доконца входил в гнездо, пришлось немного надавить, чтоб всунуть его до конца. Когда всунул, звук в наушниках был. После того как высунул, стал работать один канал. Причем и на наушниках и на динамиках. Сегодня разобрал ноутбук, думал что чтото с гнездом. Осмотр показал, что вроде как все в порядке, контакт ненарушен, гнездо визуально неповреждено. На всякий случай пропаял выводы. Звук в наушнике появился но очень тихий. Когда вынимаю штекер то динамики играют практически на одинаковой громкости, но все же левый играет чуть тише. Может ли это быть програмная ошибка? Чем можно проверить програмно?

P.S. Когда запорол выход, на ноуте была установлена Win8.1, вчера обновился до Win10. Драйвера обновились, так что проблема врят ли в драйверах.

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах
... Может ли это быть програмная ошибка? ...

Это очень маловероятно, Сергей.

... Чем можно проверить програмно? ...

Ну проверь микшером баланс влево, вправо...

Если все как ты рассказываешь - то вероятнее всего выходной усилитель на наушники (один из каналов) "подсел"

... динамики играют практически на одинаковой громкости, но все же левый играет чуть тише ...

Надо по схеме разбираться...

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах
Гость химик

Ну проверь микшером баланс влево, вправо...

Если все как ты рассказываешь - то вероятнее всего выходной усилитель на наушники (один из каналов) "подсел"

Баланс проверял, громче неделаеться.

Как понять - вход подсел?

Если я правильно понял, по схеме разьем наушников идет прямо на ЦАП без развязки. Получаеться что ЦАП испорчен?

scheme-hp-pavilion-g4-g6-g7-quanta_r23_sabin_rev_1a_.pdf

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

1) Я бы для начала взял заведомо исправные наушники с нормальным штеккером, не требующим доработок напильником и послушал выход ноута.

 

2) На плате ноута стоит не просто ЦАП, там высокоинтегрированный кодек - ЦАП и АЦП и ещё кое-что в одном флаконе.

К кодеку не только наушники напрямую подключаются, но и встроенные динамики (причём на другие ноги). Это означает, что УЗЧ тоже интегрировано в чип.

Разъём наушников не простой, там есть доп. контакты, например, SENSE_PHONE.

Если вы повредили разъём (это очень вероятно), то внешним осмотром это не проверяется никак.

Так вот, если в поврежденном разъёме что-то коротило не туда, то УЗЧ мог и пострадать.

А возможно продолжает вредить раненый разъём.

 

Выпаять разъём будет сложно. Проще сдуть индуктивности L39, L42 и подключить тестовый разъём для наушников перед ними. Так же гляньте сотпрот R480, R482 (оба 16 Ом) - это единственное препятствие на линиях от кодека.

 

Если резисторы исправны и тестовое прямое включение наушников не устранило неисправность, то вероятно кодеку пипец.

 

К сожалению, это мои чисто логические умозаключения, не основанные на железячном опыте. :wink:

Будем рады советам практиков!

 

Серёга, удачи в ремонте!

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах
Гость химик

1) Я бы для начала взял заведомо исправные наушники с нормальным штеккером, не требующим доработок напильником и послушал выход ноута.

 

2) На плате ноута стоит не просто ЦАП, там высокоинтегрированный кодек - ЦАП и АЦП и ещё кое-что в одном флаконе.

К кодеку не только наушники напрямую подключаются, но и встроенные динамики (причём на другие ноги). Это означает, что УЗЧ тоже интегрировано в чип.

Разъём наушников не простой, там есть доп. контакты, например, SENSE_PHONE.

Если вы повредили разъём (это очень вероятно), то внешним осмотром это не проверяется никак.

Так вот, если в поврежденном разъёме что-то коротило не туда, то УЗЧ мог и пострадать.

А возможно продолжает вредить раненый разъём.

 

Выпаять разъём будет сложно. Проще сдуть индуктивности L39, L42 и подключить тестовый разъём для наушников перед ними. Так же гляньте сотпрот R480, R482 (оба 16 Ом) - это единственное препятствие на линиях от кодека.

 

Если резисторы исправны и тестовое прямое включение наушников не устранило неисправность, то вероятно кодеку пипец.

 

К сожалению, это мои чисто логические умозаключения, не основанные на железячном опыте. :wink:

Будем рады советам практиков!

 

Серёга, удачи в ремонте!

1. Первым делом так и сделал. На трех парах наушников все одинаково.

2. На разьемах крышки на защелке. Я их вскрыл, визуально под лупой поломок нету. Коротить тоже неможет, контакты хорошо изолированы друг от друга. После воткнул пустой штекер и прозвонил от контактов штекера на плату. Все в порядке.

Выпаять действительно сложно, пытался (паяльной станцией). Напаял к его контактам на плате дополнительный разьем - результат тот же. Похоже кодеку пипец :wink:.

Мог ли он испортиться при замыкании выхода на массу либо каналов между собой?

Прийдеться похоже собирать или покупать внешний Цап.

P.S. А вот детали между цапом и гнездом непроверял :sad:

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах
... Как понять - вход подсел? ...

Не вход, а выход...

Где-то сигнал "протекает" на землю.

Сергей - химик: , на Ваш вопрос

... Мог ли он испортиться при замыкании выхода на массу либо каналов между собой? ...

Игорь - Datagor: ранее ответил

... УЗЧ тоже интегрировано в чип ...
... если в поврежденном разъёме что-то коротило не туда, то УЗЧ мог и пострадать. ...

Но.. не надо сразу

... собирать или покупать внешний Цап. ...

Не все так трагично 8-)

Есть еще шанс.

Вы сами отметили...

... детали между цапом и гнездом непроверял ...

Страница 26 Вашей схемы.

Там стоят емкости - C476, C491, - 1000 pFx50V и C483, C488 - 0.1 x10V.

Эти емкости при определенных условиях могут течь на землю.

Если попробовать их поменять на заведомо исправные, или местами их поменять с левого на правый канал (если получится). Только по очереди, чтобы не "потерять" ситуацию.

Изменено пользователем StalKer

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Вероятней всего все таки поврежден разъем. Например на одном из контактов содрали покрытие, и он подокислился, или еще что то подобное...

Ну вот что проще если уж и схема есть, проверить сопротивление от 31-32 пина 92HD80 до заведомо качественного джека?

Именно до джека а не до разъема на плате.

 

Всегда радовала привычка нашего человека "Если разъем не втыкается, надо нажать посильнее..." ну оно ведь не просто так не втыкается...

 

В моей практике был случай, на ноуте разъем наушников был совмещен с оптическим S/PDIF, что то попало в разъем какая то маленькая дробинка-песчинка. Человек не долго думая всадил разъем для наушников с усилием, "Ну что там может быть, разъем для наушников всегда открыт с другого конца, да и что там сломать можно..." и долго удивлялся что у то у него микруху кодека вынесло к фигам...

 

Динамики ноута могли всегда играть на чуть разной громкости, и на это просто никогда не обращали внимания, или банально подзабита грязью решетка выхода звука,

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах
Гость химик

Наконец то руки дошли (или лень прошла :biggrin: ). Как и было написано выше - виновны оказались резисторы R480, R482 и один из конденсаторов на 1000р. Правда обозначения на схеме и на плате не совпадают но это не так важно.

post-2789-0-10146600-1487865551_thumb.jpg

post-2789-0-27495100-1487865566_thumb.jpg

Начал с того, что по очереди замкнул пинцетом резисторы и индуктивности. При замыкании резисторов громкость увеличилась в разы но все же небольшая разница в уровне ощущалась. Резисторы сдул, площадки коротнул капелькой олова. После отпаял кондер С636 - уровни звука нормализовались. Резисторы R299, R308 на плате отсутствовали. На этом ремонт окончен.

 

Проверил оба канала осциллографом с помощью виртуального генератора. Уровни одинаковые, амплитуда в диапазоне 15ГЦ - 20кГц не изменяется. До этого на правом канале амплитуда резко падала после 6,8кГц.

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Серёг, а я шо говорил? :idea:

Поздравляю!

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах
Гость химик

Рано обрадовался. Уровень звука то востановился, но звук стал не таким как раньше. В низких нет резкости, они стали какими то ватными что ли. При прослушивании металла создается впечатление, что в сабвуфере имеют место стоячие волны. В общем на полную громкость долго не послушаешь, утомляет. Те же самые треки воспроизводимые со смартфона звучат четко, динамично, бас четкий. Раньше до поломки выхода на ноутбуке он, субъективно, по качеству воспроизведения переигрывал смартфон. Теперь наоборот.

То, что я удалил резисторы 16 Ом, я думаю не могло так отразиться на звуке? Неужели ЦАП подпортился?

Изменено пользователем химик

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Сергей, разумеется следует полностью ВОССТАНОВИТЬ заводскую схему!

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Создайте аккаунт или войдите для комментирования

Вы должны быть пользователем, чтобы оставить комментарий

Создать аккаунт

Зарегистрируйтесь для получения аккаунта. Это просто!

Зарегистрировать аккаунт

Войти

Уже зарегистрированы? Войдите здесь.

Войти сейчас

  • Сейчас на странице   0 пользователей

    Нет пользователей, просматривающих эту страницу

︽ Наверх страницы ︽
×